Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000011OCamlOCaml generalpublic1999-12-20 11:401999-12-20 11:43
Reporteradministrator 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionno change required 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0000011: problem with -with-pthread under Digital Unix 4.0
DescriptionFull_Name: Vincent Poirriez
Version: 2.99
OS:
Submission from: estephe.inria.fr (128.93.11.95)
Submitted by: xleroy


pour info, lors de l'installation de la 2.99 sur dec alpha avec egcs
options de config: -with-pthread
   
Vincent

 ../../boot/ocamlrun ../../boot/ocamlc -I ../../stdlib -I ../../utils -I
../../ty
ping -I ../../bytecomp -o extract_crc dynlink.cma extract_crc.cmo
gcc -O -I../../byterun -fno-defer-pop -Wall -Wno-unused -D_REENTRANT -c
posix.c
In file included from
/usr/local/lib/gcc-lib/alphaev56-dec-osf4.0b/egcs-2.91.57/
include/excpt.h:85,
                 from
/usr/local/lib/gcc-lib/alphaev56-dec-osf4.0b/egcs-2.91.57/
include/pthread_exception.h:147,
                 from /usr/local/include/pthread.h:282,
                 from posix.c:19:
/usr/include/pdsc.h:506: warning: `/*' within comment
In file included from /usr/local/include/pthread.h:290,
                 from posix.c:19:
/usr/include/c_asm.h:193: parse error before `asm'
posix.c: In function `caml_mutex_finalize':
posix.c:454: warning: passing arg 1 of `stat_free' discards `volatile'
from poin
ter target type
posix.c: In function `caml_condition_finalize':
ter target type
*** Exit 1
Stop.
*** Exit 1

TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0002060)
administrator (administrator)
1999-12-20 11:42

> pour info, lors de l'installation de la 2.99 sur dec alpha avec egcs
> options de config: -with-pthread
> In file included from /usr/local/include/pthread.h:290,
> from posix.c:19:
> /usr/include/c_asm.h:193: parse error before `asm'

C'est un probleme connu de certaines versions de Digital Unix 4.0
(4.0D en particulier): les includes systeme contiennent des constructions
"asm" qui sont specifiques au compilateur cc de DUnix et que gcc ne comprend
pas. Je crois que ce probleme est corrige dans des versions plus recentes
de Digital Unix.

- Xavier

- Issue History
Date Modified Username Field Change
2005-11-18 10:13 administrator New Issue


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker