Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001310OCamlOCaml generalpublic2002-08-08 21:052002-08-09 14:27
Reporteradministrator 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0001310: problemes installation OCaml 3.05
DescriptionFull_Name: Sebastien Ailleret
Version: 3.05
OS: linux
Submission from: 193.253.33.41 (193.253.33.41)


Bonjour,

Je suis un grand fan de Caml qui essaye d'introduire ce magnifique langage chez
un grand constructeur automobile :-)

Alors que je pensais que le changement de version serait une formalité (en
utilisant les rpms), voici les problemes que j'ai rencontre :
- le rpm s'installe sans probleme (rpm pour rh73 sur rh72 tres patchee), et la
compilation marche tres bien. Cependant, a l'execution, plantage immédiat
(section 'IM' is missing en bytecode, seg fault en opt). J'ai donc installe à
partir du source.

- le programme suivant, qui fonctionnait sous 3.04, provoque un assert false :
type t = Uin | Uout
let rec manage_utils = function
  | ((i, Uin) | (i, Uout)), Uout -> ()
  | ((i, Uin) | (i, Uout)), Uin -> ()

Sincerement

Sebastien

TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0001020)
administrator (administrator)
2002-08-09 14:27

Fixed 2002-08-09 by Luc.

- Issue History
Date Modified Username Field Change
2005-11-18 10:13 administrator New Issue


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker