Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001317OCamlOCaml generalpublic2002-08-10 11:052002-08-19 10:40
Reporteradministrator 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0001317: Assertion failure in ocaml 3.05 typechecker
DescriptionDear OCaml team,

Compiling PXP (with new installations of the latest versions of all its
support libraries) using ocaml 3.05 under OSX, I get this:

  ocamlfind ocamlopt -package "netstring" -c pxp_document.ml
  Fatal error: exception Assert_failure("typing/ctype.ml", 49467, 49479)

Is this a known problem? Is there a workaround?

Thanks,

   Benjamin

TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0001023)
administrator (administrator)
2002-08-12 21:00

> > Compiling PXP (with new installations of the latest versions of all its
> > support libraries) using ocaml 3.05 under OSX, I get this:
> >
> > ocamlfind ocamlopt -package "netstring" -c pxp_document.ml
> > Fatal error: exception Assert_failure("typing/ctype.ml", 49467, 49479)
> >
> > Is this a known problem? Is there a workaround?
>
> Not known, I believe.
> However, I couldn't reproduce this bug with the current CVS ocaml,
> using pxp-1.1.5 and ocamlnet-0.93.
> So I hope it was solved magically...

OK, I hope so too... (By the way, for the record, I was also using
pxp-1.1.5 and ocamlnet-0.93. And the standard 3.05 source distribution.)

    B

(0001024)
administrator (administrator)
2002-08-13 09:31

> Compiling PXP (with new installations of the latest versions of all its
> support libraries) using ocaml 3.05 under OSX, I get this:
>
> ocamlfind ocamlopt -package "netstring" -c pxp_document.ml
> Fatal error: exception Assert_failure("typing/ctype.ml", 49467, 49479)
>
> Is this a known problem? Is there a workaround?

Not known, I believe.
However, I couldn't reproduce this bug with the current CVS ocaml,
using pxp-1.1.5 and ocamlnet-0.93.
So I hope it was solved magically...

   Jacques

(0001025)
administrator (administrator)
2002-08-19 10:40

Dear Benli,

> Compiling PXP (with new installations of the latest versions of all its
> support libraries) using ocaml 3.05 under OSX, I get this:
>
> ocamlfind ocamlopt -package "netstring" -c pxp_document.ml
> Fatal error: exception Assert_failure("typing/ctype.ml", 49467, 49479)
>
> Is this a known problem? Is there a workaround?

Gerd Stolpmann reported this problem within 24h of the 3.05 release.
On his (and ours) machines, it manifests itself as a segmentation
fault in the compiler. It's actually a GC bug. At any rate, this is
fixed in 3.06.

Cheers,

- Xavier

(0001026)
administrator (administrator)
2002-08-19 10:40

Same bug as PR#1273.

- Issue History
Date Modified Username Field Change
2005-11-18 10:13 administrator New Issue


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker