Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001438OCamlOCaml generalpublic2002-10-14 18:322013-08-31 12:46
Reporteradministrator 
Assigned To 
PrioritynormalSeverityfeatureReproducibilityalways
StatusclosedResolutionsuspended 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0001438: minor feature request: printf and binary digits
DescriptionScanf supports reading binary via %i, but Printf does not support
printing binary (%b is taken by boolean, which is symmetric with
scanf). Perhaps %B?

Chris


TagsNo tags attached.
Attached Files

- Relationships
related to 0001675closed printf "%b" 

-  Notes
(0000140)
administrator (administrator)
2002-10-15 12:33

> Scanf supports reading binary via %i, but Printf does not support
> printing binary (%b is taken by boolean, which is symmetric with
> scanf). Perhaps %B?
>
> Chris

You will be glad to know that the working sources for Scanf and Printf
treat %b as binary notation for integers and %B as a boolean Caml token
(symetrically to %C and %S).

An experimental binary printing implementation is also included in
Printf. It has to be reworked and generalized (or drastically
simplified) but is functionning.

Best regards,

Pierre Weis

INRIA, Projet Cristal, Pierre.Weis@inria.fr, http://pauillac.inria.fr/~weis/ [^]


(0000141)
administrator (administrator)
2003-07-01 18:29

Implemented by PW 2002-10-15
removed by DD 2003-07-01 because of incompatibility problems (PR#1675)
(0006800)
doligez (administrator)
2012-01-25 16:07

There doesn't seem to be much demand for this feature. If someone can come up with a compelling argument, a good choice of letter (given that B and b are already taken), and a patch, we might include it.

- Issue History
Date Modified Username Field Change
2005-11-18 10:13 administrator New Issue
2012-01-25 16:03 doligez Relationship added related to 0001675
2012-01-25 16:07 doligez Note Added: 0006800
2012-01-25 16:07 doligez Status acknowledged => resolved
2012-01-25 16:07 doligez Resolution open => suspended
2012-01-25 16:07 doligez Description Updated View Revisions
2013-08-31 12:46 xleroy Status resolved => closed


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker