Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000245OCamlOCaml generalpublic2000-12-10 13:392012-03-24 15:01
Reporteradministrator 
Assigned Tofrisch 
PrioritynormalSeverityfeatureReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version3.13.0+dev 
Summary0000245: Suggestion: List.iteri
Description(* val iteri : (int -> 'a -> unit) -> 'a list -> unit = <fun> *)
let iteri (f:int -> 'a -> unit) (list:'a list) =
  let rec iteri2 f n = function
      [] -> ()
    | a::l -> f n a; iteri2 f (n+1) l in
  iteri2 f 0 list

I had to add the explicit typing, since the infered typing of the f is
f:int -> 'a -> 'b

----
Mattias

P.s I asked for where to find the source of ocamlwin, but I got no answer
P.P.s I never reach a bootstrap fixpoint for cygwin, but directly when using
redhat 6.2, probably the bootstrap-check doesn't work for cygwin.



TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0003281)
administrator (administrator)
2002-11-06 17:10

not enough demand
(0005700)
frisch (developer)
2010-11-05 09:16

List.iteri and List.mapi have been added to the trunk.

- Issue History
Date Modified Username Field Change
2005-11-18 10:14 administrator New Issue
2010-11-05 09:14 frisch Assigned To => frisch
2010-11-05 09:14 frisch Status closed => assigned
2010-11-05 09:16 frisch Note Added: 0005700
2010-11-05 09:16 frisch Status assigned => resolved
2010-11-05 09:16 frisch Fixed in Version => 3.13.0+dev
2010-11-05 09:16 frisch Resolution won't fix => fixed
2012-03-24 15:01 xleroy Status resolved => closed


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker