Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003555OCamlOCaml generalpublic2005-03-23 12:232011-05-29 12:14
Reporteradministrator 
Assigned Toxclerc 
PrioritynormalSeverityfeatureReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version3.11.1+dev 
Summary0003555: .ocamldebug init file would be nice
DescriptionFull_Name: mattias waldau
Version: 3.8.0.2
OS: linux/winxp
Submission from: c-048ae253.09-253-7570701.cust.bredbandsbolaget.se (83.226.138.4)


It would be nice if ocamldebug instructions like

directory ~/home/src/

and

bigstep 100000

could be placed in a file called .ocamlinit which is placed in the local
directory.

Then ocamldebug can read this file on startup.

(I currently have a project were some files are located at ../ and each time I
forgot
to add the directory, ocamldebug exists with an error.)

TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0003622)
mattiasw (reporter)
2006-04-18 09:32

This feature is still wanted.

Maybe, you should set smallstep to 1000 and bigstep to 100000 default for cygwin, since otherwise, ocamldebug very seldom works.
(0005001)
xclerc (developer)
2009-06-22 10:32

This feature has been implemented in branch "release311".
A file named ".ocamldebug" is searched first in the current directory,
and then in the home directory (using Sys.getenv "HOME"). If such a
file is found, its content is evaluated in the debugger (discarding any
line that begins with "#").

- Issue History
Date Modified Username Field Change
2005-11-18 10:13 administrator New Issue
2006-04-18 09:32 mattiasw Note Added: 0003622
2009-05-18 16:02 xleroy Status acknowledged => assigned
2009-05-18 16:02 xleroy Assigned To => xclerc
2009-06-22 10:32 xclerc Note Added: 0005001
2009-06-22 10:32 xclerc Status assigned => resolved
2009-06-22 10:32 xclerc Fixed in Version => 3.11.1+dev
2009-06-22 10:32 xclerc Resolution open => fixed
2011-05-29 12:14 xleroy Status resolved => closed


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker