Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003662OCamlOCaml generalpublic2005-05-24 21:432013-07-29 07:43
Reporteradministrator 
Assigned Togasche 
PrioritynormalSeverityfeatureReproducibilityalways
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version4.00.0 
Summary0003662: more helpful error message with incompatible .cmis
DescriptionFull_Name: henri dubois-ferriere
Version: 3.08.3
OS: debian
Submission from: lsne-catv-dhcp-41-122.urbanet.ch (80.238.41.122)


i just upgraded to 3.08.3, and by mistake did a 'make' in a directory which had
.cmi's compiled with 3.07 still lying around.

the error message was "misc.mli is not a compiled interface"

it would be good (esp for beginners who might get confused) if the error message
could say "this interface is compiled with another version of ocaml" or stg like
that.

thanks
henri

TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0009964)
gasche (developer)
2013-07-29 07:43

Things should work as expected since (at least) 4.00.

- Issue History
Date Modified Username Field Change
2005-11-18 10:13 administrator New Issue
2013-07-29 07:43 gasche Note Added: 0009964
2013-07-29 07:43 gasche Status acknowledged => resolved
2013-07-29 07:43 gasche Fixed in Version => 4.00.0
2013-07-29 07:43 gasche Resolution open => fixed
2013-07-29 07:43 gasche Assigned To => gasche


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker