Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000376OCamlOCaml generalpublic2001-06-04 15:272001-06-05 09:57
Reporteradministrator 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0000376: compiling error on 3.00
DescriptionFull_Name: Andy Larkum
Version: 3.00
OS: Linux
Submission from: onions.mcc.wwwcache.ja.net (194.82.103.143)


When trying to run 'make world' I get the error:

Unbound module Unix


This fails on line 18 of fileevent.mli, which can be found in:

otherlibs/labltk/support

Thanks

Andy

TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000578)
administrator (administrator)
2001-06-05 03:10

> When trying to run 'make world' I get the error:
>
> Unbound module Unix
>
>
> This fails on line 18 of fileevent.mli, which can be found in:
>
> otherlibs/labltk/support

That's rather strange. You should first fail in otherlibs/unix.

Some version of Linux had problems with 3.00, so a first step is probably to
upgrade to 3.01, which corrects many bugs.

Jacques Garrigue
(0000579)
administrator (administrator)
2001-06-05 09:41

> When trying to run 'make world' I get the error:
> Unbound module Unix
> This fails on line 18 of fileevent.mli, which can be found in:
> otherlibs/labltk/support

I'm pretty sure this is fixed in 3.01, available from the usual place
(http://caml.inria.fr/ [^]).

- Xavier Leroy

(0000580)
administrator (administrator)
2001-06-05 09:57

Fixed in 3.01.
(0000581)
administrator (administrator)
2001-06-05 15:28

Thanks for the quick reply.

I have used the RPM for Redhat 7 to install ocaml. Seems to have installed
ok (except that if I try to unistall, it says it's not installed!?).

The problem I have now is that I want to compile some softare that was
written on an older version of oCaml. In the makefile is has some members:

camlp4o
camlp4r

and some others. These don't appear to exist on my system. Have I done
something wrong, or have these been updated, if so to what.

If you could suggest what I might try, I'd really appreciate it.

Thanks

Andy


Mr Andrew Larkum
High Speed Networks Group
Dept. Electronic and Electrical Engineering
Loughborough University
Leics.
LE11 3TU

Tel: 01509 22 70 79
Fax: 01509 22 70 14
http://www.lboro.ac.uk/departments/el/research/hsn/ [^]
----- Original Message -----
From: "Jacques Garrigue" <caml-bugs@pauillac.inria.fr>
To: <A.Larkum@lboro.ac.uk>
Sent: Tuesday, June 05, 2001 2:10 AM
Subject: Re: compiling error on 3.00 (PR#376)


> > When trying to run 'make world' I get the error:
> >
> > Unbound module Unix
> >
> >
> > This fails on line 18 of fileevent.mli, which can be found in:
> >
> > otherlibs/labltk/support
>
> That's rather strange. You should first fail in otherlibs/unix.
>
> Some version of Linux had problems with 3.00, so a first step is probably
to
> upgrade to 3.01, which corrects many bugs.
>
> Jacques Garrigue
>
>

(0000582)
administrator (administrator)
2001-06-05 17:29

Hi,

On Tue, Jun 05, 2001 at 04:28:13PM +0200, A.Larkum@lboro.ac.uk wrote:

> camlp4o
> camlp4r
>
> and some others. These don't appear to exist on my system. Have I done
> something wrong, or have these been updated, if so to what.

You need Camlp4, with the same version than OCaml's. See at:
     http://caml.inria.fr/camlp4/ [^]

If it is not the latest version of OCaml (3.01), go to the directory OLD
of the ftp (or http) distribution.

--
Daniel de RAUGLAUDRE
daniel.de_rauglaudre@inria.fr
http://cristal.inria.fr/~ddr/ [^]


- Issue History
Date Modified Username Field Change
2005-11-18 10:13 administrator New Issue


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker