Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004128OCamlOCaml generalpublic2006-10-03 00:032007-02-21 15:50
Reporterromildo 
Assigned Togarrigue 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.09.3 
Target VersionFixed in Version3.09.4+dev / +rc 
Summary0004128: Program segfaults
DescriptionSome particular combination of arguments in a callback function for lablgtk makes the program crash with a segmentation fault, on the x86 arch.

The test program gui.ml works on amd64, and crashes on x86, with ocaml-3.09.3.

It works on both amd64 and x86, with ocaml-3.08.3 and with ocaml-3.09.2.
Additional InformationTested on both Gentoo Linux x86 and amd64 system, installed on an Athlon 64 machine with 512MB.
TagsNo tags attached.
Attached Files? file icon gui.ml [^] (5,930 bytes) 2006-10-03 00:03 [Show Content]

- Relationships
related to 0004110closedxleroy Strange code generation bug 

-  Notes
(0003802)
garrigue (manager)
2006-10-03 01:50

It looks like the problem is already resolved in the release309 branch... 1 day after 3.09.3. There is a commit by Xavier in i386/proc.ml, and I verified that the current version does not cause a segfault, while 3.09.3 does.

- Issue History
Date Modified Username Field Change
2006-10-03 00:03 romildo New Issue
2006-10-03 00:03 romildo File Added: gui.ml
2006-10-03 01:48 garrigue Relationship added related to 0004110
2006-10-03 01:50 garrigue Status new => resolved
2006-10-03 01:50 garrigue Fixed in Version => 3.09.3+dev / +rc
2006-10-03 01:50 garrigue Resolution open => fixed
2006-10-03 01:50 garrigue Assigned To => garrigue
2006-10-03 01:50 garrigue Note Added: 0003802
2007-02-21 15:49 xleroy Status resolved => closed
2007-02-21 15:50 xleroy Fixed in Version 3.09.3 => 3.09.4+dev / +rc


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker