Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004225OCamlOCaml generalpublic2007-03-11 13:412009-03-31 13:06
Reportergerd 
Assigned Toertai 
PriorityhighSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.10+dev 
Target VersionFixed in Version3.10.0 
Summary0004225: Staged installation of 3.10beta
DescriptionIn previous versions of ocaml it was possible to do a staged installation by setting PREFIX (or the triple BINDIR, LIBDIR, MANDIR) when installing ocaml, like in

make install PREFIX=stagedir

This is no longer possible in 3.10 because camlp4 and ocamlbuild are installed from a shell script that directly sources config/config.sh to get these variables, and overriding on the command line has no effect.

Of course, this is an undocumented feature, but nevertheless worth keeping it. All packagers will be thankful if this could be fixed.
Additional InformationThe fix could be to pass PREFIX, BINDIR, LIBDIR, MANDIR explicitly from Makefile to the script.
TagsNo tags attached.
Attached Files

- Relationships
related to 0004255closed Support for $DESTDIR on install 

-  Notes
(0003986)
ertai (developer)
2007-03-21 15:06

Fixed in CVS

- Issue History
Date Modified Username Field Change
2007-03-11 13:41 gerd New Issue
2007-03-11 14:47 ertai Assigned To => ertai
2007-03-11 14:47 ertai Priority normal => high
2007-03-11 14:47 ertai Status new => assigned
2007-03-21 15:06 ertai Note Added: 0003986
2007-03-21 15:06 ertai Status assigned => resolved
2007-03-21 15:06 ertai Resolution open => fixed
2007-04-04 23:42 doligez Relationship added related to 0004255
2009-03-31 13:06 xleroy Status resolved => closed
2009-03-31 13:06 xleroy Fixed in Version => 3.10.0


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker