Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004302OCamlCamlp4public2007-05-25 17:502010-04-29 14:26
Reporterhirokawa 
Assigned Toertai 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.10.0 
Target VersionFixed in Version3.10+dev 
Summary0004302: fail to parse list comprehension
DescriptionCamlp4ListComprehension.ml fails to parse the code:

  # [ x | x <- []; not x; y <- [] ];;
  Parse error: [item] expected after ";" (in [comprehension_or_sem_expr_for_list])

This is because test_patt_lessminus mishandles ";".
(I did not realize this bug when I submitted the file. Sorry.)

Here is a patch:

Camlp4ListComprehension.ml, line 52:
- | Some (KEYWORD ("as" | "::" | ";" | "," | "_"))
+ | Some (KEYWORD ("as" | "::" | "," | "_"))
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0004078)
ertai (developer)
2007-05-27 18:37

Thank you, fixed in CVS.

- Issue History
Date Modified Username Field Change
2007-05-25 17:50 hirokawa New Issue
2007-05-27 18:37 ertai Note Added: 0004078
2007-05-27 18:37 ertai Assigned To => ertai
2007-05-27 18:37 ertai Status new => resolved
2007-05-27 18:37 ertai Resolution open => fixed
2007-05-27 18:37 ertai Fixed in Version => 3.10+dev
2010-04-29 14:26 xleroy Status resolved => closed


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker