Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004313OCamlOCaml generalpublic2007-06-12 14:352010-04-29 14:26
Reporterdbuenzli 
Assigned Toertai 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.10.0 
Target VersionFixed in Version3.10+dev 
Summary0004313: ocamlbuild -log doesn't consistently (and cleanly) report inexistent directories
DescriptionGo into a directory where there is no b and _build directory.

> cd /tmp
> rm -rf _build b
> ocamlbuild -log b/_log
Fatal error: exception Sys_error("/private/tmp/b/_log: No such file or directory")
Raised at file "stdlib/lazy.ml", line 70, characters 51-52
Called from file "ocamlbuild/shell.ml", line 46, characters 15-88
Re-raised at file "stdlib/lazy.ml", line 71, characters 12-13
Called from file "ocamlbuild/log.ml", line 36, characters 55-73
Called from file "ocamlbuild/log.ml", line 38, characters 28-72
Called from file "ocamlbuild/log.ml", line 39, characters 18-34
Called from file "ocamlbuild/ocamlbuild.ml", line 15, characters 0-28

Now if I do the same a second time nothing is reported :

> ocamlbuild -log b/_log

Another thing is that the _log seems to be created before the _build hence if I try to use ocamlbuild with -log _build/_log after an ocamlbuild -clean, the first error is triggered.

And please (feature) make the _log in _build by default, it's a one line change and makes it easier for other tools (and humans) to ignore build artefacts (with respect to that I would also make the -no-links the default since the feature is anyway limited).

Best,

Daniel
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0004346)
ertai (developer)
2007-11-22 19:55

Thanks for the report. This is now fixed in the CVS (both in trunk and release310 branch).

- Issue History
Date Modified Username Field Change
2007-06-12 14:35 dbuenzli New Issue
2007-11-10 15:25 xleroy Status new => assigned
2007-11-10 15:25 xleroy Assigned To => ertai
2007-11-22 19:55 ertai Note Added: 0004346
2007-11-22 19:55 ertai Status assigned => resolved
2007-11-22 19:55 ertai Resolution open => fixed
2007-11-22 19:55 ertai Fixed in Version => 3.10+dev
2010-04-29 14:26 xleroy Status resolved => closed


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker