Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004314OCamlCamlp4public2007-06-12 16:012010-04-29 14:25
Reporterfrisch 
Assigned Toertai 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version3.11+dev 
Summary0004314: Problème de localisation des erreurs avec Camlp4
DescriptionSoit l'expression mal typée

(int_of_string "1" : unit)


Si l'on preprocesse avec Camlp4, l'erreur:

This expression has type int but is here used with type unit

pointe sur la sous-expression "1" (ie l'argument de l'application et non l'application elle-même).
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0004648)
ertai (developer)
2008-10-03 16:44

This is now fixed in the CVS HEAD version.

Thank to Jerome Vouillon for finding the cause of the bug!

- Issue History
Date Modified Username Field Change
2007-06-12 16:01 frisch New Issue
2007-11-10 15:25 xleroy Status new => assigned
2007-11-10 15:25 xleroy Assigned To => ertai
2008-10-03 16:44 ertai Note Added: 0004648
2008-10-03 16:45 ertai Status assigned => resolved
2008-10-03 16:45 ertai Resolution open => fixed
2008-10-03 16:45 ertai Fixed in Version => 3.11+dev
2010-04-29 14:25 xleroy Status resolved => closed


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker