Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004361OCamlOCaml generalpublic2007-08-11 12:042007-11-21 18:11
ReporterBoris Yakobowski 
Assigned To 
PrioritynormalSeveritytweakReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.10+dev 
Target VersionFixed in Version3.10+dev 
Summary0004361: Mix between calls to print_* functions from Pervasives et Format
DescriptionThe function highlight_dumb of Location.ml takes as argument a formatter, writes something on it using Format.fprintf (the characters locations for Emacs), and then writes the excerpt from the source code using calls to functions of Pervasives, thus ignoring the formatter. If that function is used any with anything else than std_formatted as the destination, the display is messed up.
Also, the function highlight_terminfo above completely ignores its formatter argument.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0004203)
xleroy (administrator)
2007-10-25 10:54

Formatters add an additional layer of buffering. There is no other solution than to flush the formatter before outputting data using Pervasives functions.
(0004339)
doligez (administrator)
2007-11-21 18:11

Fixed highlight_dumb in 3.10.1+dev3.
For highlight_terminfo, I added a flush of the formatter
at the beginning of the function. We can't do more
because the Terminfo functions can't output to a formatter.

- Issue History
Date Modified Username Field Change
2007-08-11 12:04 Boris Yakobowski New Issue
2007-10-25 10:54 xleroy Note Added: 0004203
2007-10-25 10:54 xleroy Status new => closed
2007-10-25 10:54 xleroy Resolution open => won't fix
2007-11-21 18:11 doligez Note Added: 0004339
2007-11-21 18:11 doligez Resolution won't fix => fixed
2007-11-21 18:11 doligez Fixed in Version => 3.10+dev


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker