Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004403OCamlOCaml generalpublic2007-09-24 19:062011-05-29 12:14
Reporterblume 
Assigned Toxclerc 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.10+dev 
Target VersionFixed in Version3.11.1+dev 
Summary0004403: ocamldebug does not support -pack'ed modules
Descriptionocamldebug gets confused when loading a program using modules created by -pack.
If the program contains several packages containing modules with the same name,
e.g.,

  Foo1.Bar1
  Foo1.Bar2
  Foo2.Bar1
  Foo2.Bar2

then it will display the source code of, say, Foo1.Bar1 whenever the program
executes code in either Foo1.Bar1 or Foo2.Bar1. Furthermore, the break command
does not work:

  break Foo1.Bar1.some_function

results in "unknown identifier ..."

  break @ Foo1.Bar1 0000056

results in "syntax error"

  break @ Bar1 0000056

results in "there is no event at that location"

(All error messages reported from memory.)
TagsNo tags attached.
Attached Filestgz file icon pack_debug.tgz [^] (1,178 bytes) 2008-11-11 12:43

- Relationships

-  Notes
(0004731)
paul_stravers (reporter)
2008-11-11 13:00

I checked with the latest CVS (tag: release311) but the problem is still present. Our company (10 engineers, rapidly growing) develops in ocaml and bug 4403 has been nagging us for some time...

To reproduce the problem with a small example, untar the attached file `pack_debug.tgz', type `make' in the unpacked directory, then follow the script in README.

If there is anything we can do to contribute to the resolution of PR 4403, please let us know.

Kind regards,
Paul Stravers
(0004921)
xleroy (administrator)
2009-04-19 11:14

Improved ocamldebug's handling of packed modules (X. Clerc). Will go in 3.11.1.

- Issue History
Date Modified Username Field Change
2007-09-24 19:06 blume New Issue
2007-11-10 14:13 xleroy Status new => assigned
2007-11-10 14:13 xleroy Assigned To => doligez
2008-11-11 12:43 paul_stravers File Added: pack_debug.tgz
2008-11-11 13:00 paul_stravers Note Added: 0004731
2009-04-01 18:36 xleroy Assigned To doligez => xclerc
2009-04-19 11:14 xleroy Note Added: 0004921
2009-04-19 11:14 xleroy Status assigned => resolved
2009-04-19 11:14 xleroy Resolution open => fixed
2009-04-19 11:14 xleroy Fixed in Version => 3.11.1+dev
2011-05-29 12:14 xleroy Status resolved => closed


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker