Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004411OCamlOCaml generalpublic2007-10-02 09:402009-03-31 13:08
Reporterfrancesco 
Assigned Toxleroy 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.10.0 
Target VersionFixed in Version3.10.0 
Summary0004411: ocamlrun crashes calling Unix.access on Windows
DescriptionMicrosoft Windows XP [Versione 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

c:\>ocaml
        Objective Caml version 3.10.0

# #load "unix.cma";;
# Unix.access "" [Unix.X_OK];;

At this point Windows displays a message that the application died.
With other access_permission parameters it works.
Probably for the same reason, I can't open the shell with OCamlBrowser.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0004175)
xleroy (administrator)
2007-10-09 16:35

The Windows/CRT version of access() does not implement the X_OK check.
Old versions of the CRT would either return an error or ignore the X_OK bit.
Newer versions do so-called "parameter validation" which, by default, does a "Watson" crash reporting.

Sort-of fixed in 3.10 development branch by treating X_OK as R_OK, i.e. just test that file is readable. It looks like the best effort we can do at this moment. Will document it in manual.

Fix needs testing.


- Issue History
Date Modified Username Field Change
2007-10-02 09:40 francesco New Issue
2007-10-09 16:35 xleroy Note Added: 0004175
2007-10-09 16:35 xleroy Status new => resolved
2007-10-09 16:35 xleroy Resolution open => fixed
2007-10-09 16:35 xleroy Status resolved => assigned
2007-10-09 16:35 xleroy Assigned To => xleroy
2007-10-09 16:36 xleroy Status assigned => resolved
2009-03-31 13:08 xleroy Status resolved => closed
2009-03-31 13:08 xleroy Fixed in Version => 3.10.0


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker