Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004430OCamlOCamldocpublic2007-10-24 11:112013-07-12 17:40
Reporterdbuenzli 
Assigned Toguesdon 
PrioritynormalSeverityfeatureReproducibilityalways
StatusconfirmedResolutionreopened 
PlatformOSOS Version
Product Version3.10.0 
Target VersionFixed in Version 
Summary0004430: ocamldoc -css-style doesn't seem to work.
Descriptionocamldoc when invoked with -css-style doesn't generate any css file.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0004188)
dbuenzli (reporter)
2007-10-24 13:13
edited on: 2012-09-15 11:21

Sorry, replace ocamlbuild by ocamldoc.

[ed: done]

(0004189)
guesdon (manager)
2007-10-24 14:07

This option does not generate a css file, but is used to indicate the url of the style sheet to reference in the html files generated by ocamldoc. A css file is generated in the output directory, called style.css. This file is always generated, except if it already exists.
(0004190)
dbuenzli (reporter)
2007-10-24 15:10

Hello Maxence,

Sorry, I didn't understand. But then I suggest you clarify the documentation since it says :

-css-style filename
Use filename as the Cascading Style Sheet file.

So I thought filename would be used to generate style.css. Maybe :

-css-style uri
Use uri as the Cascading Style Sheet file of generated files.

However I think something as I understood is needed because the current behaviour of not generating a file only if style.css is already present in the directory does not play nicely with ocamlbuild which generates everything in a directory that can be safely erased. Thus if you want to use a custom style file you need to copy your style.css after generation in the documentation directory (i.e. understand too much of the underdocumented ocamlbuild). An easy way of having a custom style while using ocamlbuild .odocl would be nice. But I don't know if it is a matter of changing ocamlbuild or ocamldoc.

Best,

Daniel

P.S.
Just to clarify, you say a style.css is always generated unless it already exists, to which I add or if -css-style is not used.
(0004191)
dbuenzli (reporter)
2007-10-24 15:11

In my preceding message _not used_ -> used.
(0007711)
doligez (administrator)
2012-07-11 16:04

Fix the documentation, then reclassify this as a feature wish.
(0008160)
guesdon (manager)
2012-09-25 09:57

Documentation fixed in revision 12955.

- Issue History
Date Modified Username Field Change
2007-10-24 11:11 dbuenzli New Issue
2007-10-24 13:13 dbuenzli Note Added: 0004188
2007-10-24 14:07 guesdon Note Added: 0004189
2007-10-24 14:07 guesdon Assigned To => guesdon
2007-10-24 14:07 guesdon Status new => closed
2007-10-24 14:07 guesdon Resolution open => no change required
2007-10-24 15:10 dbuenzli Status closed => feedback
2007-10-24 15:10 dbuenzli Resolution no change required => reopened
2007-10-24 15:10 dbuenzli Note Added: 0004190
2007-10-24 15:11 dbuenzli Note Added: 0004191
2012-07-11 16:04 doligez Note Added: 0007711
2012-07-11 16:04 doligez Status feedback => confirmed
2012-07-11 16:04 doligez Target Version => 4.01.0+dev
2012-07-31 13:37 doligez Target Version 4.01.0+dev => 4.00.1+dev
2012-09-15 11:21 doligez Target Version 4.00.1+dev => 4.00.2+dev
2012-09-15 11:21 doligez Summary ocamlbuild -css-style doesn't seem to work. => ocamldoc -css-style doesn't seem to work.
2012-09-15 11:21 doligez Description Updated View Revisions
2012-09-15 11:21 doligez Note Edited: 0004188 View Revisions
2012-09-25 09:57 guesdon Note Added: 0008160
2012-09-25 09:58 guesdon Severity minor => feature
2013-07-12 17:40 doligez Target Version 4.00.2+dev =>


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker