Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004521OCamlCamlp4public2008-03-19 17:392010-04-29 14:25
Reporterhirokawa 
Assigned Toertai 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.10.2 
Target VersionFixed in Version3.11+dev 
Summary0004521: Camlp4 produces wrong location information
Descriptioncamlp4o and camlp4r produces a wrong location for `e1 e2'.

$ cat a.ml
float 1

$ ocamlc -pp camlp4o -c -dtypes a.ml
$ cat a.annot
"a.ml" 1 0 0 "a.ml" 1 0 5
type(
  int -> float
)
"a.ml" 1 0 6 "a.ml" 1 0 7
type(
  float
)
"a.ml" 1 0 6 "a.ml" 1 0 7
type(
  int
)

The last item should be ``"a.ml" 1 0 0 "a.ml" 1 0 7''; cf.

$ ocamlc -c -dtypes a.ml
$ cat a.annot
"a.ml" 1 0 0 "a.ml" 1 0 5
type(
  int -> float
)
"a.ml" 1 0 6 "a.ml" 1 0 7
type(
  int
)
"a.ml" 1 0 0 "a.ml" 1 0 7
type(
  float
)
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0004625)
ertai (developer)
2008-09-23 02:10

This bug is now fixed in the CVS HEAD version.

Thank to Jerome Vouillon for finding the cause of the bug!

- Issue History
Date Modified Username Field Change
2008-03-19 17:39 hirokawa New Issue
2008-03-25 16:16 doligez Assigned To => ertai
2008-03-25 16:16 doligez Status new => acknowledged
2008-09-23 02:10 ertai Note Added: 0004625
2008-09-23 02:10 ertai Status acknowledged => resolved
2008-09-23 02:10 ertai Resolution open => fixed
2008-09-23 02:10 ertai Fixed in Version => 3.11+dev
2010-04-29 14:25 xleroy Status resolved => closed


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker