Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004627OCamlOCaml generalpublic2008-10-27 15:422014-02-19 20:44
Reporterguesdon 
Assigned To 
PrioritylowSeverityminorReproducibilityalways
StatusclosedResolutionwon't fix 
PlatformOSOS Version
Product Version3.11.0+beta 
Target VersionFixed in Version 
Summary0004627: gestion d'un ';' bizarre
DescriptionA votre avis, comment ce code doit-il être parsé ?

let f x =
  let y = x + 1 in
  if y > 2 then
    begin
      prerr_endline "coucou"
    end;
    prerr_endline "coucou bis";
    (* coucou *) ;
    y

Le code est bien parsé et termine avec
  Line 10, chars 4-5: Unbound value y

Au contraire, le code suivant
  let f x = ignore(x) ; (* coucou *) ; x
ne parse pas, le ';' après le commentaire provoquant une erreur:
 Line 1, chars 35-36: Syntax error


TagsNo tags attached.
Attached Files

- Relationships
related to 0006327acknowledged Puzzling infinite loop with oddly accepted program 

-  Notes
(0004695)
doligez (administrator)
2008-10-29 13:48

Je suis pas super chaud pour changer la grammaire, on risque toujours l'incompatibilite.
Est-ce que ca pose vraiment un probleme en pratique ? Ca date au moins de 3.06, et
peut-etre meme de 3.00...

En tout cas ca ne sera pas fixe pour 3.11.0.

(0005266)
guesdon (manager)
2010-03-08 18:45

Ne serait-ce pas simplement un problème de priorité ? J'étais tombé dessus par hasard, et une fois seulement mais ça peut perturber.
(0006898)
doligez (administrator)
2012-02-07 20:30

This is not just a precedence problem. I have a simple fix but it breaks mldonkey, which has an instance of this syntax (probably not on purpose).

Since this is not a problem in practice, and fixing it risks breaks some existing programs, we will not fix it.

- Issue History
Date Modified Username Field Change
2008-10-27 15:42 guesdon New Issue
2008-10-29 13:48 doligez Note Added: 0004695
2008-10-29 13:48 doligez Severity major => minor
2008-10-29 13:48 doligez Status new => acknowledged
2010-03-08 18:45 guesdon Note Added: 0005266
2012-02-07 20:30 doligez Note Added: 0006898
2012-02-07 20:30 doligez Priority high => low
2012-02-07 20:30 doligez Status acknowledged => resolved
2012-02-07 20:30 doligez Resolution open => won't fix
2013-08-05 11:04 guesdon Status resolved => closed
2014-02-19 20:44 doligez Relationship added related to 0006327


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker