Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004639OCamlOCamlbuild (the tool)public2008-11-05 18:392011-05-29 12:14
Reporterygrek 
Assigned Toertai 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.11.0+beta 
Target VersionFixed in Version3.11.0 
Summary0004639: ocamlbuild tries to delete _build/_log and fails and whole build fails (windows)
DescriptionStR:
Create empty directory. Create empty file myocamlbuild.ml. Run
ocamlbuild -classic-display
AcR:
mkdir _build
ocamlopt -I "C:\Program\ocaml\lib\ocamlbuild" unix.cmxa "C:\Program\ocaml\lib\ocamlbuild/ocamlbuildlib.cmxa" myocamlbuild.ml "C:\Program\ocaml\lib\ocamlbuild/ocamlbuild.cmx" -o myocamlbuild
Exception Sys_error("_build/_log: Permission denied").

Another StR:
Create empty directory. Run
ocamlbuild -clean -classic-display
AcR:
rm: cannot remove `_build/_log': Permission denied

For now I have to use -no-log because of this.
Looks like Windows blocks file from deleting because it is opened by ocamlbuild itself?
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0005011)
ygrek (reporter)
2009-07-06 12:13

I cannot reproduce it with 3.11.0
(0005017)
ertai (developer)
2009-07-10 14:46

Indeed it has been resolved in 3.11

- Issue History
Date Modified Username Field Change
2008-11-05 18:39 ygrek New Issue
2008-11-12 14:57 doligez Status new => assigned
2008-11-12 14:57 doligez Assigned To => ertai
2009-07-06 12:13 ygrek Note Added: 0005011
2009-07-10 14:46 ertai Note Added: 0005017
2009-07-10 14:46 ertai Status assigned => resolved
2009-07-10 14:46 ertai Resolution open => fixed
2009-07-10 14:46 ertai Fixed in Version => 3.11.0
2011-05-29 12:14 xleroy Status resolved => closed
2012-02-02 15:17 protz Category OCamlbuild => OCamlbuild (the tool)


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker