Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004641OCamlOCaml generalpublic2008-11-07 10:172013-09-04 18:05
Reporterandrejbauer 
Assigned Toxleroy 
PrioritynormalSeverityfeatureReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.10.2 
Target VersionFixed in Version3.12.0+dev 
Summary0004641: Bit manipulation for Big_int
DescriptionThe Big_int module in the Num library would benefit greatly from two simple additions: functions which can shift numbers left and right a given number of bits (the equivalent of asl, lsl, asr, lsr for the type int). Please consider adding them. I am willing to write a patch if someone tells me they will consider it.
Additional InformationI am implementing real number computation in Ocaml, for which I am using the MPFR library. Since MPFR is hard to compile and link with Ocaml (requires a bunch of other tools and libraries), I have decided to reimplement dyadic rationals in "pure" Ocaml. To my shock I discovered that the Big_int package doesn't have the bit shifting operations. So now I have to divide by powers of two, which is really inefficient.
TagsNo tags attached.
Attached Files

- Relationships
related to 0004652acknowledged Big_Int random numbers 

-  Notes
(0004898)
xleroy (administrator)
2009-04-01 18:21

On the CVS trunk, I added big_int implementations for bitwise operations, shifts, and bit extraction. More testing is welcome. If all goes well, this will be released in 3.12.0.

- Issue History
Date Modified Username Field Change
2008-11-07 10:17 andrejbauer New Issue
2008-11-12 14:58 doligez Status new => acknowledged
2009-04-01 18:21 xleroy Note Added: 0004898
2009-04-01 18:21 xleroy Status acknowledged => resolved
2009-04-01 18:21 xleroy Resolution open => fixed
2009-04-01 18:22 xleroy Fixed in Version => 3.12.0+dev
2009-04-01 18:23 xleroy Assigned To => xleroy
2011-05-29 12:14 xleroy Status resolved => closed
2013-09-04 18:05 doligez Relationship added related to 0004652


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker