Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004650OCamlOCaml generalpublic2008-11-25 17:272011-05-29 12:14
ReporterAHuebner 
Assigned Toxleroy 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.10.2 
Target VersionFixed in Version3.11.1+dev 
Summary0004650: regexp_case_fold does not work correctly with an exclusion set
DescriptionWhen using an exclusion character set, regexp_case_fold produces incorrect results.

# #load "str.cma" ;;
# open Str ;;
# string_match (regexp_case_fold "[^a]") "a" 0 ;;
- : bool = true

This is due to the set being first "negated" (everything but 'a', including 'A') and applying case_fold afterwards. ('A' will lead to 'a' in the final set.)
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0004796)
xleroy (administrator)
2008-12-12 09:54

Tentative fix in 3.11 release branch. Should go in 3.11.1.

- Issue History
Date Modified Username Field Change
2008-11-25 17:27 AHuebner New Issue
2008-11-26 11:17 xleroy Status new => assigned
2008-11-26 11:17 xleroy Assigned To => xleroy
2008-12-12 09:54 xleroy Note Added: 0004796
2008-12-12 09:54 xleroy Status assigned => resolved
2008-12-12 09:54 xleroy Resolution open => fixed
2009-04-19 11:00 xleroy Fixed in Version => 3.11.1+dev
2011-05-29 12:14 xleroy Status resolved => closed


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker