Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004738OCamlOCaml generalpublic2009-03-06 14:242013-08-31 12:46
Reporterdbuenzli 
Assigned To 
PrioritynormalSeveritytweakReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.11.0 
Target VersionFixed in Version3.12.0 
Summary0004738: OCaml's distribution should provide a single build procedure
DescriptionThere are currently two separate build procedures (make or ocamlbuild). There are discrepancies between the result of the two (e.g. see [1]) and besides all your good work I expect to see more of these kind of bugs.

To keep everyone (users and dev. team) sane I think the dev. team should choose a single build procedure and stick to it.

Best,

Daniel

[1] http://caml.inria.fr/mantis/view.php?id=4691 [^]
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0005592)
dbuenzli (reporter)
2010-07-06 15:43
edited on: 2010-07-13 17:29

Other examples:

http://caml.inria.fr/mantis/view.php?id=5093 [^]
http://caml.inria.fr/mantis/view.php?id=5103 [^]

(0006917)
doligez (administrator)
2012-02-13 17:59

Since 3.12.0, the ocamlbuild procedure is no longer mentioned in the INSTALL file, and I would go so far as to say it's unsupported.

- Issue History
Date Modified Username Field Change
2009-03-06 14:24 dbuenzli New Issue
2009-04-29 15:38 doligez Status new => acknowledged
2010-07-06 15:43 dbuenzli Note Added: 0005592
2010-07-13 17:29 dbuenzli Note Edited: 0005592
2012-02-13 17:59 doligez Note Added: 0006917
2012-02-13 17:59 doligez Status acknowledged => resolved
2012-02-13 17:59 doligez Resolution open => fixed
2012-02-13 17:59 doligez Fixed in Version => 3.12.0
2013-08-31 12:46 xleroy Status resolved => closed


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker