Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004874OCamlOCaml generalpublic2009-09-23 14:292012-03-24 15:01
Reportervbigiani 
Assigned Toxleroy 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.11.1 
Target VersionFixed in Version3.12.0+dev 
Summary0004874: Str library: digits match \b
DescriptionThe digits (0-9) match againt \b, as can be demonstrated by the following snippet:

let reg = Str.regexp "a\\b";;
Str.string_match reg "a1" 0;;

which should return false, but instead returns true (because 1 is considered a word boundary).
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0005460)
xleroy (administrator)
2010-05-19 14:25

Changed the notion of word constituent in Str so that they include digits 0-9 and the _ character in addition to letters. This is more consistent with other regexp packages (Perl, Python, egrep).

- Issue History
Date Modified Username Field Change
2009-09-23 14:29 vbigiani New Issue
2010-05-19 14:25 xleroy Note Added: 0005460
2010-05-19 14:25 xleroy Status new => resolved
2010-05-19 14:25 xleroy Resolution open => fixed
2010-05-19 14:29 xleroy Assigned To => xleroy
2010-05-19 14:29 xleroy Fixed in Version => 3.12.0+dev
2012-03-24 15:01 xleroy Status resolved => closed


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker