Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004876OCamlOCaml generalpublic2009-09-24 14:102011-05-29 12:20
Reporterjean-louis Colaco 
Assigned Toxclerc 
PrioritynormalSeveritymajorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.11.0 
Target VersionFixed in Version3.12.0+dev 
Summary0004876: error in string to integers conversions
DescriptionWhen converting a string representing (max_int + 1), the function returns a negative value instead of raising an Overflow.
This Bug is present on native integer, Int32 and Int64.
TagsNo tags attached.
Attached Files

- Relationships
duplicate of 0004210closedxleroy little bug in int_of_string 

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2009-09-24 14:10 jean-louis Colaco New Issue
2009-09-24 14:35 xclerc Relationship added duplicate of 0004210
2009-09-24 14:36 xclerc Duplicate ID 0 => 4210
2009-09-24 14:36 xclerc Status new => resolved
2009-09-24 14:36 xclerc Fixed in Version => 3.12.0+dev
2009-09-24 14:36 xclerc Resolution open => fixed
2009-09-24 14:36 xclerc Assigned To => xclerc
2011-05-29 12:20 xleroy Status resolved => closed


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker