Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004972OCamlCamlp4public2010-02-04 14:332012-03-24 15:01
Reporterjoe 
Assigned Toxclerc 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.11.2 
Target VersionFixed in Version3.12.1+dev 
Summary0004972: mkcamlp4 does not include dynlink.cma
DescriptionThe executable mkcamlp4 does not include dynlink.cma which is required by camlp4 as of version 3.11. This library is impossible to add by the user since the inclusion of the camlp4 library precludes all other arguments. The fix is trivial. Simply, line 64 of mkcamlp4.ml must be changed to:

  run (["ocamlc"; "-I"; camlp4_standard_library; "dynlink.cma"; "camlp4lib.cma"; crc_ml]

This forces the inclusion of dynlink.cma prior to that of camlp4lib.cma.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2010-02-04 14:33 joe New Issue
2010-02-04 14:33 joe Status new => assigned
2010-02-04 14:33 joe Assigned To => ertai
2010-07-22 11:43 ertai Assigned To ertai => xclerc
2010-12-29 14:46 xclerc Status assigned => resolved
2010-12-29 14:46 xclerc Fixed in Version => 3.12.1+dev
2010-12-29 14:46 xclerc Resolution open => fixed
2012-03-24 15:01 xleroy Status resolved => closed


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker