Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0004996OCamlOCaml generalpublic2010-03-09 16:412011-05-29 12:19
Reporterrose 
Assigned Toxleroy 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.11.2 
Target VersionFixed in Version3.12.0+dev 
Summary0004996: Subst.compose is coded wrongly.
DescriptionCorrect me if I am wrong, but after studying the code for substitutions in subst.ml I think, that 'Subst.compose' is wrong. It should concatenate two substitutions 'suba' and 'subb', but in fact only concatenates entries, which are already present in 'subb'. If 'subb' is the identity (empty tables), the composition should be 'suba', but is in fact also wrongly the identity substitution. The function 'Subst.compose' is only used for relocation of debugging info when packaging CMO-files. Therefore I think this makes the debugger unhappy with packed CMO-files. There is already a bug about this topic, but its closed. But the reason for that bug might not come from the debugger itself, but is possibly present because of this issue with 'compose'.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0005353)
xleroy (administrator)
2010-04-20 16:13

Well spotted. I fixed the implementation so that it is a proper composition. We will see what impacts this has on debug info for packed modules, but I optimistically assume it can only make them better. Will go in 3.12.0.

- Issue History
Date Modified Username Field Change
2010-03-09 16:41 rose New Issue
2010-04-20 16:13 xleroy Note Added: 0005353
2010-04-20 16:13 xleroy Status new => resolved
2010-04-20 16:13 xleroy Resolution open => fixed
2010-04-20 16:13 xleroy Fixed in Version => 3.12.0+dev
2010-04-22 09:16 xleroy Assigned To => xleroy
2011-05-29 12:19 xleroy Status resolved => closed


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker