Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005016OCamlOCaml generalpublic2010-04-03 23:532011-05-29 12:19
Reporterdiekhans 
Assigned Toremy 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.11.2 
Target VersionFixed in Version3.12.0+dev 
Summary0005016: inf-caml.el globally overwrites comint-output-filter-function
Descriptioninferior-caml-mode-output-hook in inf-caml.el globally overwrite the value of
comint-output-filter-function for all comint buffers, not just the inferior-caml-mode
buffer.

This can result in passwords in shell mode being exposed, hence the severity of major.

A patch is attached
TagsNo tags attached.
Attached Filespatch file icon inf-caml.el.patch [^] (464 bytes) 2010-04-03 23:53 [Show Content]

- Relationships

-  Notes
(0005382)
remy (manager)
2010-04-27 08:49
edited on: 2010-04-27 14:08

The proposed patch would have the global effect of making comint-output-filter-functions buffer-local, thus
changing its behavior for other modes. This is unecessary,
since comint-output-filter-functions can be set locally with set-variable
function.


- Issue History
Date Modified Username Field Change
2010-04-03 23:53 diekhans New Issue
2010-04-03 23:53 diekhans File Added: inf-caml.el.patch
2010-04-18 11:05 xleroy Status new => assigned
2010-04-18 11:05 xleroy Assigned To => remy
2010-04-27 08:49 remy Note Added: 0005382
2010-04-27 08:50 remy Note Edited: 0005382
2010-04-27 10:25 remy Status assigned => resolved
2010-04-27 10:25 remy Resolution open => fixed
2010-04-27 10:25 remy Fixed in Version => 3.12.0+dev
2010-04-27 14:08 remy Note Edited: 0005382
2011-05-29 12:19 xleroy Status resolved => closed


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker