Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005039OCamlOCamlbuild (the tool)public2010-04-28 17:532012-03-24 15:01
Reportergildor 
Assigned Toxclerc 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version3.12.1+dev 
Summary0005039: Fix to findlib support and -linkpkg
DescriptionIn ocamlbuild/ocaml_specific.ml l548
flag ["ocaml"; "link"] & A"-linkpkg";

should be replaced by
flag ["ocaml"; "link"; "program"] & A"-linkpkg";

-linkpkg shoudl only be applied to program, otherwise it includes libraries in libraries (i.e. Unix in yourlib.cmxa).
TagsNo tags attached.
Attached Files

- Relationships
related to 0005217closedxclerc ocamlfind plugin should add -linkpkg for toplevel too 

-  Notes
(0005708)
yziquel (reporter)
2010-11-14 22:16

Is this bug so difficult to solve? It seems to me that this is a rather important bug in the sense that it does impact ocamlbuild-ocamlfind interaction, which is sort of sad since the -use-ocamlfind option makes things so easy... apart from this bug.

- Issue History
Date Modified Username Field Change
2010-04-28 17:53 gildor New Issue
2010-04-29 14:33 xleroy Status new => assigned
2010-04-29 14:33 xleroy Assigned To => ertai
2010-07-22 11:43 ertai Assigned To ertai => xclerc
2010-11-14 22:16 yziquel Note Added: 0005708
2010-11-29 11:11 xclerc Status assigned => resolved
2010-11-29 11:11 xclerc Fixed in Version => 3.12.1+dev
2010-11-29 11:11 xclerc Resolution open => fixed
2011-02-10 16:08 xclerc Relationship added related to 0005217
2012-02-02 15:17 protz Category OCamlbuild => OCamlbuild (the tool)
2012-03-24 15:01 xleroy Status resolved => closed


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker