Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005041OCamlOCaml generalpublic2010-05-02 01:152010-05-21 13:46
Reporterjessicah 
Assigned To 
PrioritynormalSeveritytrivialReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.11.2 
Target VersionFixed in Version3.12.0+dev 
Summary0005041: Make new build system work on *BSD
DescriptionMakefiles require GNU make, but using the build/*.sh scripts don't take this into account.
Additional InformationAttached patch to modify a couple of the build/*.sh scripts to use $MAKE instead of make, and define MAKE=make if not defined.

P.S. patch actually generated from 3.12.0+dev svn, but looks like those files haven't changed much at all :)
TagsNo tags attached.
Attached Filespatch file icon ocaml-buildsystem.patch [^] (1,122 bytes) 2010-05-02 01:15 [Show Content]

- Relationships

-  Notes
(0005484)
doligez (administrator)
2010-05-21 13:46

Only ocamlbuild needs gnu make. I've fixed this but I'm using GNUMAKE instead of MAKE.

- Issue History
Date Modified Username Field Change
2010-05-02 01:15 jessicah New Issue
2010-05-02 01:15 jessicah File Added: ocaml-buildsystem.patch
2010-05-21 13:46 doligez Note Added: 0005484
2010-05-21 13:46 doligez Status new => closed
2010-05-21 13:46 doligez Resolution open => fixed
2010-05-21 13:46 doligez Fixed in Version => 3.12.0+dev


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker