Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005071OCamlCamlp4public2010-06-14 15:212012-09-25 20:06
Reporteredwin 
Assigned Toxclerc 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.11.2 
Target VersionFixed in Version3.12.1+dev 
Summary0005071: "camlp4 -parser r -parser rp" accept original syntax, not equivalent to camlp4r
DescriptionThe Camlp4 wiki (http://brion.inria.fr/gallium/index.php/Using_Camlp4 [^]) says that
camlp4r is equivalent to "camlp4 -parser r -parser rp -printer a".

However "camlp4 -parser r -parser rp -printer a" seems to accept original syntax, not the revised one!
It doesn't give error on original syntax only, while camlp4r gives error on original syntax.

Testcase:
1. cat >test.ml <<EOF
let globalvalue = 4;;
EOF
2. camlp4r test.ml
File "test.ml", line 1, characters 18-19:
Parse error: "in" expected after [binding] (in [expr])
3. camlp4 -parser r -parser rp -printer a test.ml
let globalvalue = 4
4. cat >test2.ml <<EOF
value globalvalue = 4;
5. camlp4r test2.ml
let globalvalue = 4
6. camlp4 -parser r -parser rp -printer a test2.ml
(value globalvalue) = 4
Additional InformationLooks like '-parser rp' loads the original syntax too:
$ camlp4 -parser r -parser rp -loaded-modules
Camlp4OCamlParser
Camlp4OCamlRevisedParser
Camlp4OCamlRevisedParserParser

$ camlp4 -parser rp -loaded-modules
Camlp4OCamlParser
Camlp4OCamlRevisedParser
Camlp4OCamlRevisedParserParser
camlp4r doesn't load it:
$ camlp4r -loaded-modules
Camlp4.Printers.OCaml
Camlp4OCamlRevisedParser
Camlp4OCamlRevisedParserParser

I think '-parser rp' is meant to load RevisedParserParser, but for some reason it loads the original syntax too (Camlp4OCamlParser), which makes the input language original syntax (not revised).
TagsNo tags attached.
Attached Files

- Relationships
related to 0005129closedxclerc camlp4of differs from camlp4 -parser of 
related to 0005134closedxclerc camlp4r differs from camlp4 -parser rp 

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2010-06-14 15:21 edwin New Issue
2010-06-14 15:21 edwin Status new => assigned
2010-06-14 15:21 edwin Assigned To => ertai
2011-02-15 15:16 xclerc Relationship added related to 0005129
2011-02-15 15:17 xclerc Relationship added related to 0005134
2011-02-15 15:17 xclerc Assigned To ertai => xclerc
2011-02-15 15:18 xclerc Status assigned => resolved
2011-02-15 15:18 xclerc Fixed in Version => 3.12.1+dev
2011-02-15 15:18 xclerc Resolution open => fixed
2012-09-25 20:06 xleroy Status resolved => closed


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker