Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005095OCamlOCamlbuild (the tool)public2010-07-08 12:102012-03-24 15:01
Reportergsutre 
Assigned Toxclerc 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.12.0+beta1 or 3.12.0+rc1 
Target VersionFixed in Version3.12.1+dev 
Summary0005095: pp(...) tag used for *.cmx but ignored for *.cmo
DescriptionConsider the following example:

$ cat _tags
<*.cmo>: pp(foo)
<*.cmx>: pp(foo)
$ ocamlbuild -classic-display A.cmo A.cmx
/usr/pkg/bin/ocamldep.opt -modules A.ml > A.ml.depends
/usr/pkg/bin/ocamlc.opt -c -o A.cmo A.ml
/usr/pkg/bin/ocamlopt.opt -c -pp foo -o A.cmx A.ml

Here, the pp(foo) tag is ignored for the *.cmo declaration, but it is
used for the *.cmx declaration. Is this behavior intended? The code
says (ocaml_specific.ml):

pflag ["ocaml"; "compile"] "pp"
    (fun param -> S [A "-pp"; A param]);

So I wonder why pp(foo) only applies to *.cmx.
Additional InformationThis bug report is extracted from the following message that I sent to the
caml mailing list:

http://caml.inria.fr/pub/ml-archives/caml-list/2010/06/f1c5394a6d6f0c4b50dc1fd176cac09d.en.html [^]
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0005719)
xclerc (developer)
2010-11-25 16:12

You were right, the parametrized flag was defined for any compiler.
However, in "ocaml_compiler.ml", the "byte_compile_ocaml_implem"
was only looking for tags attached to the source file, and not for
tags attached to the object file to be produced (while its native
equivalent was correctly looking for the union of tag sets).

- Issue History
Date Modified Username Field Change
2010-07-08 12:10 gsutre New Issue
2010-07-22 11:38 ertai Status new => assigned
2010-07-22 11:38 ertai Assigned To => xclerc
2010-11-25 16:12 xclerc Note Added: 0005719
2010-11-25 16:12 xclerc Status assigned => resolved
2010-11-25 16:12 xclerc Fixed in Version => 3.12.1+dev
2010-11-25 16:12 xclerc Resolution open => fixed
2012-02-02 15:17 protz Category OCamlbuild => OCamlbuild (the tool)
2012-03-24 15:01 xleroy Status resolved => closed


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker