Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005111OCamlOCamldocpublic2010-07-22 00:262013-08-19 19:17
Reporterdbuenzli 
Assigned Toguesdon 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version3.12.0+beta1 or 3.12.0+rc1 
Target Version4.01.0+devFixed in Version 
Summary0005111: ocamldoc, heading tags inside spans tags is illegal in html
Descriptionocamldoc puts heading tags inside spans, as a result the pages are not valid html. It seems the only reason this is done is to put an id attribute on the heading but this can be put directly on the heading tag.

Note that in general the structure of the generated html could be reviewed to make it easier to style the output with css. For example there are quite a few annoying < br/> and < center> tags. Also there are empty < pre>< /pre> tags surrounding code blocks introduced with {[]} maybe the code block is supposed to be enclosed in a < pre> tag (?). There is also some untagged text in the body of the document, e.g. the first line under the module definition at the top of a module page.

Best,

Daniel
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0005614)
dbuenzli (reporter)
2010-07-22 00:32
edited on: 2013-08-14 14:18

Of course ocamlbuild should be subtituted by ocamldoc [ed: done]. And apparently mantis doesn't escape html properly [ed: fixed it by inserting a space after each <]. So here's again the text of the report :

ocamldoc puts heading tags inside spans, as a result the pages are not valid html. It seems the only reason this is done is to put an id attribute on the heading but this can be put directly on the heading tag.

Note that in general the structure of the generated html could be reviewed with appropriate class attributes to make it easier to style the output with css. There are also quite a few annoying br and center tags.

Also there are empty pre tag surrounding code blocks introduced with the syntax {[ ]} maybe the code block is supposed to be enclosed in a pre tag itself (?).

There is also some untagged text in the body of the document e.g. the first line under the module definition at the top of a module page.

Best,

Daniel

(0005621)
dbuenzli (reporter)
2010-07-24 22:54

Its also seems that type definition for records are not enclosed in pre tags.
(0007987)
guesdon (manager)
2012-08-27 13:52

Revisions 12886 (branch 4.00) and revision 12887 (trunk) fix the problem with the span around hX tags.
(0007988)
guesdon (manager)
2012-08-27 13:56
edited on: 2013-08-14 14:16

Regarding records definitions, it seems enclosed in < pre> now.

What do you mean about "some untagged text in the body of the document e.g. the first line under the module definition at the top of a module page." ?

(0008110)
dbuenzli (reporter)
2012-09-19 13:54

I mean the top level "List operations" here http://caml.inria.fr/pub/docs/manual-ocaml-4.00/libref/List.html [^]
(0008159)
guesdon (manager)
2012-09-25 09:51

Ok. All description is now put into a div class="info" (idem for module types, classes and class types).
Revision 12593 in version/4.00 and 12594 in trunk.
(0008944)
dbuenzli (reporter)
2013-03-03 10:14

Regarding Revision 12594. Would it be possible to characterize the div class="info" with more precise qualifiers e.g. div class = "info module synopsis" (module inside a module), div class = "info module description". Since for now it is impossible to distinguish toplevel module descriptions if you indent "info" divs for elements of a signature then the toplevel module description also gets indented.

To see what I mean see here [1], I would like to align the top level module text with the documentation text in the Basics section.

[1] http://erratique.ch/software/cmdliner/doc/Cmdliner [^]

If you indent the info for values and module
(0010111)
guesdon (manager)
2013-08-05 11:50
edited on: 2013-08-05 11:50

Now module, module type, class and class type comments at the beginning of a page are in a <div class="info X top">, where X is, respectively, "module", "modtype", "class", "classtype".

Rev 13981 in 4.01.
Rev 13982 in trunk.

This should be enough for you to prevent unwanted indentation. Is it ok ?

More generally, the HTML generator could output more precise classes for each element of the generated document. If you have time to make a proposition about this, do not hesitate.


- Issue History
Date Modified Username Field Change
2010-07-22 00:26 dbuenzli New Issue
2010-07-22 00:26 dbuenzli Status new => assigned
2010-07-22 00:26 dbuenzli Assigned To => guesdon
2010-07-22 00:32 dbuenzli Note Added: 0005614
2010-07-24 22:54 dbuenzli Note Added: 0005621
2012-07-10 20:08 doligez Description Updated View Revisions
2012-07-10 20:10 doligez Summary ocamlbuild, heading tags inside spans tags is illegal in html => ocamldoc, heading tags inside spans tags is illegal in html
2012-07-10 20:10 doligez Description Updated View Revisions
2012-07-10 20:10 doligez Target Version => 4.01.0+dev
2012-07-31 13:36 doligez Target Version 4.01.0+dev => 4.00.1+dev
2012-08-27 13:52 guesdon Note Added: 0007987
2012-08-27 13:56 guesdon Note Added: 0007988
2012-09-19 13:46 doligez Target Version 4.00.1+dev => 4.01.0+dev
2012-09-19 13:46 doligez Description Updated View Revisions
2012-09-19 13:47 doligez Note Edited: 0005614 View Revisions
2012-09-19 13:54 dbuenzli Note Added: 0008110
2012-09-25 09:51 guesdon Note Added: 0008159
2012-09-25 09:52 guesdon Status assigned => closed
2012-09-25 09:52 guesdon Resolution open => fixed
2013-03-03 10:14 dbuenzli Note Added: 0008944
2013-03-03 10:14 dbuenzli Status closed => feedback
2013-03-03 10:14 dbuenzli Resolution fixed => reopened
2013-08-05 11:50 guesdon Note Added: 0010111
2013-08-05 11:50 guesdon Resolution reopened => fixed
2013-08-05 11:50 guesdon Note Edited: 0010111 View Revisions
2013-08-14 14:12 doligez Description Updated View Revisions
2013-08-14 14:13 doligez Description Updated View Revisions
2013-08-14 14:14 doligez Description Updated View Revisions
2013-08-14 14:14 doligez Description Updated View Revisions
2013-08-14 14:15 doligez Description Updated View Revisions
2013-08-14 14:15 doligez Description Updated View Revisions
2013-08-14 14:16 doligez Note Edited: 0007988 View Revisions
2013-08-14 14:18 doligez Note Edited: 0005614 View Revisions
2013-08-19 19:17 doligez Status feedback => resolved


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker