Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005115OCamlOCaml generalpublic2010-07-28 13:272012-03-24 15:01
Reporterdoligez 
Assigned Toxleroy 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSWindowsOS Version64-bit
Product Version3.12.0 
Target VersionFixed in Version3.12.1+dev 
Summary0005115: msvc64 port produces bytecode executables that don't work on 32-bit versions
DescriptionIn the 64-bit MSVC version, output-value does the wrong thing on native ints and makes them unreadable by 32-bit versions of OCaml.

Also, if a 64-bit version of OCaml compiles a program with a large nativeint constant, the resulting bytecode will crash the 32-bit versions because they try to raise an exception before the global constants are initialized.
Steps To ReproduceBootstrap with MSVC in 64-bit mode and try to use the resulting ocamlc, e.g. under cygwin -> crash
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0005702)
xleroy (administrator)
2010-11-11 12:09

Tentative fixes for both issues in 3.12 development branch, commits #10792 and #10793.

- Issue History
Date Modified Username Field Change
2010-07-28 13:27 doligez New Issue
2010-07-28 13:27 doligez Status new => assigned
2010-07-28 13:27 doligez Assigned To => xleroy
2010-11-11 12:09 xleroy Note Added: 0005702
2010-11-11 12:09 xleroy Status assigned => resolved
2010-11-11 12:09 xleroy Resolution open => fixed
2010-11-11 12:09 xleroy Product Version 3.12.0+beta1 or 3.12.0+rc1 => 3.12.0
2010-11-11 12:09 xleroy Fixed in Version => 3.12.1+dev
2012-03-24 15:01 xleroy Status resolved => closed


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker