Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005158OCamlCamlp4public2010-09-29 13:432012-09-25 20:06
ReporterHendrik Tews 
Assigned Toxclerc 
PrioritynormalSeverityfeatureReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.12.0 
Target VersionFixed in Version3.12.1+dev 
Summary0005158: make Register.{sig,str}_item_parser accessible
DescriptionCurrently it is not possible that two independent modules modify the parsing functions via Register.register_{sig,str}_item_parser, because one cannot access the current value.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0005799)
xclerc (developer)
2011-02-10 16:32

The following functions have been added to the 'Register' module:
  - value current_parser : unit -> (parser_fun PreCast.Ast.str_item * parser_fun PreCast.Ast.sig_item);
  - value current_printer : unit -> (printer_fun PreCast.Ast.str_item * printer_fun PreCast.Ast.sig_item).

- Issue History
Date Modified Username Field Change
2010-09-29 13:43 Hendrik Tews New Issue
2010-09-29 13:43 Hendrik Tews Status new => assigned
2010-09-29 13:43 Hendrik Tews Assigned To => ertai
2011-02-09 14:42 xclerc Assigned To ertai => xclerc
2011-02-10 16:32 xclerc Note Added: 0005799
2011-02-10 16:32 xclerc Status assigned => resolved
2011-02-10 16:32 xclerc Fixed in Version => 3.12.1+dev
2011-02-10 16:32 xclerc Resolution open => fixed
2012-09-25 20:06 xleroy Status resolved => closed


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker