Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005165OCamlOCamlbuild (the tool)public2010-10-16 00:052012-03-24 15:01
Reporterhcarty 
Assigned Toxclerc 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.12.0 
Target VersionFixed in Version3.12.1+dev 
Summary0005165: ocamlbuild does not provide "-thread" option to ocamlfind when compiling with ocamlfind
DescriptionThe command

ocamlfind -tag thread -use-ocamlfind -pkg threads ...

should call ocamlfind with "-thread" or "-vmthread", otherwise the threads package can not be used.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0005686)
hcarty (reporter)
2010-10-19 23:22

An example

foo.ml:

open Thread
let () = print_endline "Hello world"

Compile with:

ocamlbuild -use-ocamlfind -pkg threads foo.native
or
ocamlbuild -use-ocamlfind -pkg threads foo.byte
or
ocamlbuild -use-ocamlfind -pkg threads foo.inferred.mli

to see the problem. It looks like the "-thread" option should be passed to ocamlfind for linking and inferring the interface.

- Issue History
Date Modified Username Field Change
2010-10-16 00:05 hcarty New Issue
2010-10-19 23:22 hcarty Note Added: 0005686
2010-11-29 11:09 xclerc Status new => resolved
2010-11-29 11:09 xclerc Fixed in Version => 3.12.1+dev
2010-11-29 11:09 xclerc Resolution open => fixed
2010-11-29 11:09 xclerc Assigned To => xclerc
2012-02-02 15:17 protz Category OCamlbuild => OCamlbuild (the tool)
2012-03-24 15:01 xleroy Status resolved => closed


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker