Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005211OCamlOCaml documentationpublic2011-01-25 23:402012-09-25 20:07
Reporterwilliam 
Assigned Toxclerc 
PrioritynormalSeverityminorReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.12.0 
Target VersionFixed in Version3.12.1+dev 
Summary0005211: genlex full documentation
Descriptionthe parser example in the Genlex documentation is not complete : it took me hours to compile a similar example with ocamlbuild.
First it is not "let parse_expr = parser [...]" but "let rec parse_expr = parser [...]".
Second, to compile this example in a file called example.ml, one needs to do :
echo "<example.ml>:pp(camlp4o)" > _tags
ocamlbuild example.d.byte
TagsNo tags attached.
Attached Files

- Relationships
has duplicate 0005298closed Genlex seems to be not working in v3.12 

-  Notes
(0005790)
william (reporter)
2011-01-25 23:42

the genlex documentation : http://caml.inria.fr/pub/docs/manual-ocaml/libref/Genlex.html [^]

- Issue History
Date Modified Username Field Change
2011-01-25 23:40 william New Issue
2011-01-25 23:42 william Note Added: 0005790
2011-05-17 16:43 doligez Status new => acknowledged
2011-06-22 13:14 xclerc Relationship added has duplicate 0005298
2011-09-15 15:04 xclerc Status acknowledged => resolved
2011-09-15 15:04 xclerc Fixed in Version => 3.12.1+dev
2011-09-15 15:04 xclerc Resolution open => fixed
2011-09-15 15:04 xclerc Assigned To => xclerc
2012-09-25 20:07 xleroy Status resolved => closed


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker