Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005230OCamlOCaml documentationpublic2011-02-21 11:152012-09-25 20:06
ReporterPascal Cuoq 
Assigned Toweis 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.12.0 
Target VersionFixed in Version 
Summary0005230: Documentation of Scanf.Scanning.open_in
DescriptionThe documentation of Scanf.Scanning.open_in reuses that of previous function from_file. Instances of "from_file" in the body of the documentation have not been renamed.

From http://caml.inria.fr/pub/docs/manual-ocaml/libref/Scanf.Scanning.html [^] :

val open_in : string -> in_channel
Bufferized file reading in text mode. The efficient and usual way to scan text mode files (in effect, from_file returns a scanning buffer that reads characters in large chunks, rather than one character at a time as buffers returned by from_channel below do). Scanning.from_file fname returns a scanning buffer which reads from the given file fname in text mode.
Since 3.12.0
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0005833)
weis (developer)
2011-02-23 17:55

Thank you Pascal for the bug report. I reviewed the entire doc of the module.
This will be available in the next bug fix release.
(0005834)
weis (developer)
2011-02-23 17:59

Just a careful documentation review.

- Issue History
Date Modified Username Field Change
2011-02-21 11:15 Pascal Cuoq New Issue
2011-02-23 17:43 weis Status new => assigned
2011-02-23 17:43 weis Assigned To => weis
2011-02-23 17:55 weis Note Added: 0005833
2011-02-23 17:59 weis Note Added: 0005834
2011-02-23 17:59 weis Status assigned => resolved
2011-02-23 17:59 weis Resolution open => fixed
2012-09-25 20:06 xleroy Status resolved => closed


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker