Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005246OCamlOCaml generalpublic2011-04-02 09:592012-09-25 20:06
ReporterChristophe Troestler 
Assigned Toxleroy 
PrioritynormalSeverityfeatureReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.13.0+dev 
Target VersionFixed in Version3.13.0+dev 
Summary0005246: Please provide the hypot function
DescriptionThis is related to 0003806 but I do not know how to reopen it.

The situation since 2005 has changed, hypot is in C99 which is becoming more pervasive and even visual studio is supporting it:
http://msdn.microsoft.com/en-us/library/a9yb3dbt%28v=VS.100%29.aspx [^]
TagsNo tags attached.
Attached Files

- Relationships
related to 0003806closed atan2 and hypot 

-  Notes
(0005890)
xleroy (administrator)
2011-05-12 17:45

That's reasonable, especially since emulating hypot() if it's not available is not too hard. Let me put that on the to do list for 3.13.
(0005969)
xleroy (administrator)
2011-06-04 10:57

Implemented in SVN trunk. Will go in release 3.13.0.

- Issue History
Date Modified Username Field Change
2011-04-02 09:59 Christophe Troestler New Issue
2011-05-02 12:57 doligez Relationship added related to 0003806
2011-05-02 12:58 doligez Status new => acknowledged
2011-05-12 17:45 xleroy Note Added: 0005890
2011-05-12 17:45 xleroy Assigned To => xleroy
2011-05-12 17:45 xleroy Status acknowledged => assigned
2011-06-04 10:57 xleroy Note Added: 0005969
2011-06-04 10:57 xleroy Status assigned => resolved
2011-06-04 10:57 xleroy Resolution open => fixed
2011-06-04 10:57 xleroy Fixed in Version => 3.13.0+dev
2012-09-25 20:06 xleroy Status resolved => closed


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker