Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005248OCamlCamlp4public2011-04-07 01:082012-09-25 20:06
Reporterlealanko 
Assigned Toxclerc 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.12.1+dev 
Target VersionFixed in Version3.12.1+dev 
Summary0005248: Single-digit int64 literals aren't parsed.
Description        Objective Caml version 3.12.1+dev6 (2011-03-06)

# #load"dynlink.cma";;
# #load"camlp4o.cma";;
    Camlp4 Parsing version 3.12.1+dev6 (2011-03-06)

# 00L;;
- : int64 = 0L
# 0L;
Error: Integer literal exceeds the range of representable integers of type int64
# 0;;
- : int = 0
# 1L;;
Error: Integer literal exceeds the range of representable integers of type int64
Additional InformationThis was due to r10943, which was a fix to 0005118.
TagsNo tags attached.
Attached Files

- Relationships
related to 0005118closedxclerc Camlp4o and integer literals 

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2011-04-07 01:08 lealanko New Issue
2011-04-07 01:08 lealanko Status new => assigned
2011-04-07 01:08 lealanko Assigned To => ertai
2011-04-07 10:20 xclerc Assigned To ertai => xclerc
2011-04-07 10:20 xclerc Status assigned => resolved
2011-04-07 10:20 xclerc Fixed in Version => 3.12.1+dev
2011-04-07 10:20 xclerc Resolution open => fixed
2011-06-08 17:03 doligez Relationship added related to 0005118
2012-09-25 20:06 xleroy Status resolved => closed


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker