Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005264OCamlOCaml documentationpublic2011-05-11 16:482013-08-31 12:46
Reporterznajem 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.12.0 
Target VersionFixed in Version3.13.0+dev 
Summary0005264: Error in example code in section 1.8
DescriptionThe parsing part of the (symbolic processing of expressions) example reports errors. The error messages are included in both the HTML and PDF versions of the release 3.12 manual.

To fix, I added the following line to the beginning of the code:
##load "dynlink.cma"

-------

As a minor suggestion, I think the example should indicate that it uses polymorphic variants (which is not introduced until section 4.2) rather than the normal variants that were introduced in section 1.4
TagsNo tags attached.
Attached Files

- Relationships
child of 0005261closed Parse errors reported by toplevel for code of section 1.8 

-  Notes
(0005885)
znajem (reporter)
2011-05-11 16:51

I see now that this has been reported earlier. I apologize for the duplication. I'll see if I can delete it.
(0005886)
xclerc (developer)
2011-05-11 17:11
edited on: 2011-05-11 17:11

You do not have to apologize; duplicates are not a big problem as long as we detect them...
Moreover, it is sometimes tricky for a reporter to successfully search for a previously reported problem.

(0005892)
doligez (administrator)
2011-05-16 16:35

let's keep it for the "minor suggestion" part
(0006909)
doligez (administrator)
2012-02-10 09:51

But the example does *not* use polymorphic variants, and I can't find any occurrence of the backquote character before section 4.2. I'm closing this report.

- Issue History
Date Modified Username Field Change
2011-05-11 16:48 znajem New Issue
2011-05-11 16:51 znajem Note Added: 0005885
2011-05-11 16:52 xclerc Relationship added duplicate of 0005261
2011-05-11 16:53 xclerc Relationship deleted 0005261
2011-05-11 16:53 xclerc Relationship added child of 0005261
2011-05-11 17:11 xclerc Note Added: 0005886
2011-05-11 17:11 xclerc Note Edited: 0005886
2011-05-16 16:35 doligez Note Added: 0005892
2011-05-16 16:35 doligez Status new => acknowledged
2012-02-10 09:51 doligez Note Added: 0006909
2012-02-10 09:51 doligez Status acknowledged => resolved
2012-02-10 09:51 doligez Resolution open => fixed
2012-02-10 09:51 doligez Fixed in Version => 3.13.0+dev
2012-02-10 09:51 doligez Description Updated View Revisions
2013-08-31 12:46 xleroy Status resolved => closed


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker