Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005269OCamlOCaml generalpublic2011-05-18 16:432012-09-25 20:06
Reporterfrisch 
Assigned Toxclerc 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version3.12.1 
Summary0005269: Wrong ext_ref entries in .annot files when the path contains sub-modules
DescriptionAn external reference to an identifier X.A.x is printed like that in the .annot file:

ident(
  ext_ref X.( A ).x
)


This is because of the function Oprint.parenthesized_ident, called in typecore.ml (function type_exp, case Pexp_ident).
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0005909)
frisch (developer)
2011-05-18 16:47

The only other use of parenthesized_ident is in the function Oprint.value_ident, which is only used in print_out_sig_item for value items. So changing parenthesized_ident by adding the range 'A'..'Z' should not have any other effect than fixing .annot files.
(0005910)
xclerc (developer)
2011-05-18 17:03

This is what I did in a tentative fix (revision 11051) in branch "version/3.12".
I should have read your note before working on the fix...

- Issue History
Date Modified Username Field Change
2011-05-18 16:43 frisch New Issue
2011-05-18 16:47 frisch Note Added: 0005909
2011-05-18 17:03 xclerc Note Added: 0005910
2011-05-18 17:04 xclerc Assigned To => xclerc
2011-05-18 17:04 xclerc Status new => assigned
2011-09-05 11:26 xclerc Status assigned => resolved
2011-09-05 11:26 xclerc Fixed in Version => 3.12.1
2011-09-05 11:26 xclerc Resolution open => fixed
2012-09-25 20:06 xleroy Status resolved => closed


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker