Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005288OCamlOCaml generalpublic2011-06-10 08:312012-09-25 20:06
Reporterlefessan 
Assigned Toxleroy 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformallOSallOS Versionall
Product Version3.12.0 
Target Version3.12.0Fixed in Version3.13.0+dev 
Summary0005288: fix escaping pattern aliases
DescriptionPattern-matching generate aliases of variables during its
compilation. Such aliases are evaluated lazily when they are used only
once. This optimization is performed even if they are used in an
abstraction, in which case they might make a bigger datastructure
escape from its scope, and lead to an important memory leak.

The following patch fixes this behavior by preventing the substitution when
aliases are used in abstractions and in loops.
TagsNo tags attached.
Attached Filespatch file icon fix-escaping-pattern-aliases-3.12.0.patch [^] (7,537 bytes) 2011-06-10 08:31 [Show Content]

- Relationships
duplicate of 0005205closedxleroy Performance bug: pushing let-alias inside loop body 

-  Notes
(0005997)
frisch (developer)
2011-06-10 09:13

I think this is a duplicate of 0005205. Now we have two patches :-)
(0005998)
lefessan (developer)
2011-06-10 09:17

You are right, I didn't understand it was the same issue, but looking at the patches, we are fixing the same problem with two different patches ;-)
(0006003)
xleroy (administrator)
2011-06-11 15:15

Implemented in SVN trunk, along the lines of Fabrice's patch but (for the time being) without the inlining of locally-let-bound functions.

- Issue History
Date Modified Username Field Change
2011-06-10 08:31 lefessan New Issue
2011-06-10 08:31 lefessan File Added: fix-escaping-pattern-aliases-3.12.0.patch
2011-06-10 09:13 frisch Note Added: 0005997
2011-06-10 09:14 frisch Relationship added duplicate of 0005205
2011-06-10 09:17 lefessan Note Added: 0005998
2011-06-11 15:15 xleroy Note Added: 0006003
2011-06-11 15:15 xleroy Assigned To => xleroy
2011-06-11 15:15 xleroy Status new => resolved
2011-06-11 15:15 xleroy Resolution open => fixed
2011-06-11 15:15 xleroy Fixed in Version => 3.13.0+dev
2012-09-25 20:06 xleroy Status resolved => closed


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker