Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005301OCamlCamlp4public2011-06-26 17:232012-09-25 20:06
ReporterDmitry Grebeniuk 
Assigned Toxclerc 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.13.0+dev 
Target VersionFixed in Version 
Summary0005301: camlp4: camlp4r: exception equal to another exception
DescriptionMaybe I'm trying to use the wrong syntax, but the error message should be more readable.

$ ocaml
        OCaml version 3.13.0+dev3

# #use "topfind";;
[..]
# #camlp4r;;
[..]
# module A = struct exception E of int; end;
module A : sig exception E of int; end
# exception Q of int = A.E;
Assertion failed, file "camlp4/Camlp4/Struct/Camlp4Ast2OCamlAst.ml", line 948, char 21
#
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0006035)
xclerc (developer)
2011-06-28 09:02

The fix is temporary because it drops the type information provided at aliasing site.
The actual type is taken from the original exception without checking that it is the
same that is provided by the alias.
(0006043)
xclerc (developer)
2011-07-12 11:41

After consultation of the AST for the original grammar,
and discussion with Nicolas Pouillard, it turns out that
the syntactic construct has to be disallowed.

Indeed, when aliasing an exception in the original syntax,
there is not way to "repeat" its type. As camlp4 has no type
information, it cannot do more than the original syntax.
Hence, the decision to forbid the syntactic construct.

However, you will now be presented a (hopefully) much
nicer error message.

- Issue History
Date Modified Username Field Change
2011-06-26 17:23 Dmitry Grebeniuk New Issue
2011-06-26 17:23 Dmitry Grebeniuk Status new => assigned
2011-06-26 17:23 Dmitry Grebeniuk Assigned To => ertai
2011-06-27 09:30 xclerc Assigned To ertai => xclerc
2011-06-27 09:35 xclerc Status assigned => resolved
2011-06-27 09:35 xclerc Fixed in Version => 3.13.0+dev
2011-06-27 09:35 xclerc Resolution open => fixed
2011-06-28 09:02 xclerc Note Added: 0006035
2011-06-28 09:02 xclerc Status resolved => feedback
2011-06-28 09:02 xclerc Resolution fixed => reopened
2011-07-12 11:41 xclerc Note Added: 0006043
2011-07-12 11:41 xclerc Status feedback => resolved
2011-07-12 11:41 xclerc Fixed in Version 3.13.0+dev =>
2011-07-12 11:41 xclerc Resolution reopened => fixed
2012-09-25 20:06 xleroy Status resolved => closed


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker