Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005333OCamlOCaml generalpublic2011-08-10 02:202013-08-31 12:44
Reporterjm 
Assigned Toprotz 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionduplicate 
PlatformGNU/LinuxOSDebianOS Versionsqueeze/amd64
Product Version3.12.1 
Target VersionFixed in Version 
Summary0005333: ocamlopt -pack leads to segfaulting code when packed and packing modules have the same name.
Description% ocamlopt -v
The OCaml native-code compiler, version 3.13.0+dev6 (2011-07-29)
Standard library directory: /usr/local/lib/ocaml
% make # using the attached Makefile
mkdir -p p
echo >p/p.ml "let f () = ()"
cd p; ocamlc -c p.ml
mkdir -p p
echo >p/pp.ml "let f () = ()"
cd p; ocamlc -c pp.ml
cd p; ocamlc -pack -o ../p.cmo p.cmo pp.cmo
echo >t.ml "let () = P.Pp.f (); print_endline \"P.Pp.f ()\""
echo >>t.ml "let () = P.P .f (); print_endline \"P.P .f ()\""
ocamlc -o t.byte p.cmo t.ml
cd p; ocamlopt -c -for-pack P p.ml
cd p; ocamlopt -c -for-pack P pp.ml
cd p; ocamlopt -pack -o ../p.cmx p.cmx pp.cmx
ocamlopt -o t.native p.cmx t.ml
./t.byte
P.Pp.f ()
P.P .f ()
./t.native
P.Pp.f ()
make: *** [all] Segmentation fault
TagsNo tags attached.
Attached Files? file icon Makefile [^] (648 bytes) 2011-08-10 02:20 [Show Content]

- Relationships
duplicate of 0004080acknowledged segfault avec ocamlopt -pack 

-  Notes
(0006097)
Julien Signoles (reporter)
2011-08-23 16:40

Seem to be the same bug than 0004080.

- Issue History
Date Modified Username Field Change
2011-08-10 02:20 jm New Issue
2011-08-10 02:20 jm File Added: Makefile
2011-08-23 16:40 Julien Signoles Note Added: 0006097
2011-12-21 15:01 protz Relationship added duplicate of 0004080
2011-12-21 15:01 protz Status new => resolved
2011-12-21 15:01 protz Resolution open => duplicate
2011-12-21 15:01 protz Assigned To => protz
2013-08-31 12:44 xleroy Status resolved => closed


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker