Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005336OCamlOCaml generalpublic2011-08-14 17:372012-09-25 20:07
Reporterglondu 
Assigned Toxleroy 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.12.1 
Target VersionFixed in Version3.12.1+dev 
Summary0005336: ocamlopt on arm must use .type directives for function symbols
DescriptionAll executables generated by ocamlopt started to segfault recently on Ubuntu armel port, following a change in ld. This is due to missing .type directives for function symbols. Attached is a patch that fixes that.

See https://bugs.launchpad.net/bugs/810402 [^] (comment 0000020 in particular on why ocamlopt is at fault here).
TagsNo tags attached.
Attached Filespatch file icon 0013-ocamlopt-arm-add-.type-directive-for-code-symbols.patch [^] (3,933 bytes) 2011-08-14 17:37 [Show Content]

- Relationships

-  Notes
(0006129)
xleroy (administrator)
2011-09-18 10:10

Thanks for the patch. Applied in 3.12 bugfix branch and in the trunk.

- Issue History
Date Modified Username Field Change
2011-08-14 17:37 glondu New Issue
2011-08-14 17:37 glondu File Added: 0013-ocamlopt-arm-add-.type-directive-for-code-symbols.patch
2011-09-18 10:10 xleroy Note Added: 0006129
2011-09-18 10:10 xleroy Assigned To => xleroy
2011-09-18 10:10 xleroy Status new => resolved
2011-09-18 10:10 xleroy Resolution open => fixed
2011-09-18 10:10 xleroy Fixed in Version => 3.12.1+dev
2012-09-25 20:07 xleroy Status resolved => closed


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker