Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005370OCamlOCaml generalpublic2011-10-04 15:142012-09-25 20:07
Reporterjfc 
Assigned Toxclerc 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.12.1 
Target VersionFixed in Version3.12.1 
Summary0005370: ocamldep omits filename in syntax error message
DescriptionRun ocamldep on this file, which has a syntax error:

let f a b = begin
  let g a = f
end

The error message has an empty string in place of the filename:

$ ocamldep bad.ml
File "", line 3, characters 0-3:
Error: Syntax error

ocamlbuild runs ocamldep first so this bad error message is annoying in practice.

(I am actually using 3.12 branch svn version 11214, "version 3.12.2+dev1 (2011-08-03)", because I need the fix for another bug. I haven't tried 3.12.1 release.)
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2011-10-04 15:14 jfc New Issue
2011-10-05 09:32 xclerc Status new => resolved
2011-10-05 09:32 xclerc Fixed in Version => 3.12.1
2011-10-05 09:32 xclerc Resolution open => fixed
2011-10-05 09:32 xclerc Assigned To => xclerc
2012-09-25 20:07 xleroy Status resolved => closed


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker