Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005382OCamlOCaml generalpublic2011-10-23 18:252013-08-31 12:48
Reportersthibaul 
Assigned Toprotz 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.12.0 
Target VersionFixed in Version 
Summary0005382: Lacks support for ENOTSUP
DescriptionHello,

On some systems such as Solaris or GNU/Hurd, ENOTSUP and EOPNOSUPP do
not have the same value, but ocaml code only deals with EOPNOSUPP, and
thus ocaml applications only handle the EOPNOSUPP case. The attached
patch fixes it by making ocaml convert ENOTSUP errors into EOPNOSUPP
errors.

Samuel
TagsNo tags attached.
Attached Files? file icon patch [^] (709 bytes) 2011-10-23 18:25 [Show Content]

- Relationships

-  Notes
(0006443)
protz (manager)
2011-12-21 14:09

Thanks for the patch, this has been fixed in revision r11915 in trunk. I'm trusting you that this is correct (and indeed it looks like it's correct) since I have no GNU/Hurd box ready to try out :-).

Cheers,

jonathan
(0006961)
glondu (reporter)
2012-02-24 08:26

Please apply this patch to branch 3.12 as well.
(0006963)
protz (manager)
2012-02-24 08:40

Fixed in svn r12185

- Issue History
Date Modified Username Field Change
2011-10-23 18:25 sthibaul New Issue
2011-10-23 18:25 sthibaul File Added: patch
2011-12-21 14:09 protz Note Added: 0006443
2011-12-21 14:09 protz Status new => resolved
2011-12-21 14:09 protz Resolution open => fixed
2011-12-21 14:09 protz Assigned To => protz
2012-02-24 08:26 glondu Note Added: 0006961
2012-02-24 08:40 protz Note Added: 0006963
2013-08-31 12:48 xleroy Status resolved => closed


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker