Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005413OCamlOCaml generalpublic2011-12-01 19:202012-09-25 20:07
Reporterberry 
Assigned Todoligez 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.12.1 
Target VersionFixed in Version 
Summary0005413: ocamldebug raises remap problem on cygwin
Descriptionwhen calling ocamldebug and running a program, I get

(ocd) run
Loading program... 1 [main] ocamlrun 1624 C:\cygwin\bin\ocamlrun.exe: ***
fatal error - unable to remap \\?\C:\cygwin\lib\ocaml\stublibs\dllunix.so to sam
e address as parent: 0x6ECD0000 != 0x0
Stack trace:
Frame Function Args
0028B578 6102796B (0028B578, 00000000, 00000000, 00000000)
0028B868 6102796B (6117EC60, 00008000, 00000000, 61180977)
0028C898 61004F1B (611A7FAC, 61243884, 6ECD0000, 00000000)
End of stack trace
      2 [main] ocamldebug 1484 fork: child 1624 - died waiting for dll loading,
errno 11
Unix error : 'fork' failed : Resource temporarily unavailable
(ocd)

I found a few posts on the Web, including one here without reply. They tell to run rebaseall on cygwin and reboot, I did it with no effect.

Best regards,
GĂ©rard Berry
TagsNo tags attached.
Attached Files

- Relationships
related to 0005400closeddoligez Le module Unix sous Cygwin ne fonctionne plus 

-  Notes
(0006309)
Kakadu (reporter)
2011-12-15 11:17

Same problem on my machine.

$ ./brb.byte build
Cannot find FLEXDLL_RELOCATE
Cannot find FLEXDLL_RELOCATE
      2 [main] ocamlrun 3156 E:\cygwin\usr\local\bin\ocamlrun.exe: *** fatal error - unable to remap \\?\E:\cygwin\usr\local\lib\ocaml\stublibs\dllunix.so to same address as parent: 0x665C0000 != 0x0
Stack trace:
Frame Function Args
0022B5B8 6102796B (0022B5B8, 00000000, 00000000, 00000000)
0022B8A8 6102796B (6117EC60, 00008000, 00000000, 61180977)
0022C8D8 61004F1B (611A7FAC, 61243594, 665C0000, 00000000)
End of stack trace
      2 [main] brb.byte 3696 fork: child 3156 - died waiting for dll loading, errno 11
Fatal error: exception Unix.Unix_error(2, "fork", "")
(0006316)
doligez (administrator)
2011-12-15 18:24

This looks like a known problem with flexdll 0.25, which affects the OCaml Cygwin package. But that is version 3.12.0 and not 3.12.1.

The Cygwin package will soon be updated to 3.12.1 without the bug.
(0006393)
xleroy (administrator)
2011-12-20 09:01

The OCaml 3.12.1 package seems to be available in Cygwin now. Could you please upgrade in Cygwin and let us know if the problem persists?
(0006400)
berry (reporter)
2011-12-20 10:08

OK, I loaded 3.12.1 from another site (mirrors do not seem all up-to-date). Now comes something different:

berry@apsara ~
# ocamldebug
Fatal error: exception Invalid_argument("inet_addr_of_string not implemented")
(0006402)
Kakadu (reporter)
2011-12-20 10:19

berry: same for me
ocaml irc says that
> ... maybe missing headers or your install of cygwin could be updated
(0006413)
berry (reporter)
2011-12-20 14:16

My cygwin install was done yesterday, so it is something else...
(0006421)
doligez (administrator)
2011-12-20 18:20
edited on: 2011-12-20 18:31

OK, I have the same problem with the new cygwin package. It seems the auto-configure script did the wrong thing when building the package. I'm looking into the problem.

(0006476)
doligez (administrator)
2011-12-21 22:43

The new cygwin package is now available (3.12.1-2). Can you try it and let me know if it works for you?
Thanks.
(0006504)
Kakadu (reporter)
2011-12-22 13:14

fixed.

- Issue History
Date Modified Username Field Change
2011-12-01 19:20 berry New Issue
2011-12-15 11:17 Kakadu Note Added: 0006309
2011-12-15 18:24 doligez Note Added: 0006316
2011-12-20 09:00 xleroy Relationship added related to 0005400
2011-12-20 09:01 xleroy Note Added: 0006393
2011-12-20 09:01 xleroy Status new => feedback
2011-12-20 10:08 berry Note Added: 0006400
2011-12-20 10:08 berry Status feedback => new
2011-12-20 10:19 Kakadu Note Added: 0006402
2011-12-20 14:16 berry Note Added: 0006413
2011-12-20 18:20 doligez Note Added: 0006421
2011-12-20 18:20 doligez Assigned To => doligez
2011-12-20 18:20 doligez Status new => assigned
2011-12-20 18:31 doligez Note Edited: 0006421 View Revisions
2011-12-21 22:43 doligez Note Added: 0006476
2011-12-22 13:14 Kakadu Note Added: 0006504
2011-12-23 14:53 doligez Status assigned => resolved
2011-12-23 14:53 doligez Resolution open => fixed
2012-09-25 20:07 xleroy Status resolved => closed


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker