Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005423OCamlOCamlbuild (the tool)public2011-12-14 15:522013-08-31 12:46
Reporternanotube 
Assigned Todoligez 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Platformx64OSSUSE LinuxOS VersionEnterprise 9
Product Version3.12.1 
Target VersionFixed in Version 
Summary0005423: x11 library path detection by configure fails under certain conditions
DescriptionX11 library path detection fails when include is in /usr/X11R6/include and the libraries are in /usr/X11R6/lib64. This causes the make world step to fail.

When we discussed this with thelema on #ocaml channel on freenode, he determined that the issue is that $x11_try_lib_dir is based on the location of include dir, with s/include/lib/. Suggested fix is to try s/include/lib64/ first.
Steps To ReproduceTry ./configure; make world; on a 64bit system with x11 includes in /usr/X11R6/include and libraries in /usr/X11R6/lib64. make world will fail at the point when it deals with the X11 libs.
Additional InformationCurrent workaround is to add "--x11lib /usr/X11R6/lib64" to ./configure arguments to force $x11_lib_dir to point to the right place.
TagsNo tags attached.
Attached Files

- Relationships
duplicate of 0005477closed ocaml graphics not working on popular Linux distros; ocaml should use pkg-config to get X11 switches 

-  Notes
(0006873)
doligez (administrator)
2012-02-03 16:18
edited on: 2012-02-06 11:32

This looks like a duplicate of PR#5477, except that this one is in the "Ocamlbuild" category instead of "OCaml internal build/install".

Is this really specific to OCamlbuild, or are we talking about the main OCaml configuration script here?

(0006916)
thelema (reporter)
2012-02-12 14:44

It is just a dupe of PR#5477.

- Issue History
Date Modified Username Field Change
2011-12-14 15:52 nanotube New Issue
2012-02-02 15:17 protz Category OCamlbuild => OCamlbuild (the tool)
2012-02-03 16:18 doligez Note Added: 0006873
2012-02-03 16:18 doligez Assigned To => doligez
2012-02-03 16:18 doligez Status new => feedback
2012-02-06 11:32 doligez Note Edited: 0006873 View Revisions
2012-02-12 14:44 thelema Note Added: 0006916
2012-02-12 14:56 protz Relationship added duplicate of 0005477
2012-02-12 14:56 protz Status feedback => resolved
2012-02-12 14:56 protz Resolution open => fixed
2013-08-31 12:46 xleroy Status resolved => closed


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker